Unmaintained space


A few weeks ago, I was playing putting water on my thinkpad, because it can normally handle it, and mostly because a friend of mine didn't believed it. The water went as usual through the laptop, but this time, I think I put a little too much, and I broke the battery loading circuits.

The result was a perfectly working motherboard, but the battery was not able to charge. That was a little embarrassing, and I decided to completely take the laptop apart to see 1) if I could see something strange around the battery, and 2) how the laptop was built exactly.

1) showed nothing, but even better, it bricked the board... Watching libreboot's output did not really helped, because I'm not a coreboot dev, and because it worked until a moment where it just stopped, without error... Hard to debug...

Still, I really needed that laptop, because during that period, I had dug my old X31 up, but this one was a bit too slow, so I bought on Ebay a second-hand motherboard for only 9€!

Putting it into the X60 went pretty good (I love how the thinkpad is done, btw!), but I faced a strange matter: the Lenovo bios couldn't boot with my Atheros Wifi card. Anyway, this was only one more good reason the flash libreboot, because it worked very good on the old motherboard, and I wanted to do it myself at least once (first time, I bought the laptop from Gluglug and it came preflashed).

This went very well thanks to libreboot's tutorial and I was now able to use my laptop with a very new and state-of-the-art software for an even better hardware!